# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d+)(st|nd|rd)/nth/gm;t' <<< "Liverpool to score 2 goals in 1st 90 minutes
"