const regex = /(\d+)(st|nd|rd)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+)(st|nd|rd)', 'gm')
const str = `Liverpool to score 2 goals in 1st 90 minutes
`;
const subst = `nth`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);