$re = '/(\d+)(st|nd|rd)/m';
$str = 'Liverpool to score 2 goals in 1st 90 minutes
';
$subst = "nth";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;