use strict;
my $str = 'Liverpool to score 2 goals in 1st 90 minutes
';
my $regex = qr/(\d+)(st|nd|rd)/mp;
my $subst = 'nth';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";