// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d+)(st|nd|rd)").unwrap();
let string = "Liverpool to score 2 goals in 1st 90 minutes
";
let substitution = "nth";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}