import Foundation
let pattern = #"GEO[P|L]\_(.*)\_JGEM"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"GEOL_Laramide_Fault_Density_Cu_JGEM"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)