// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)GEO[P|L]\_(.*)\_JGEM").unwrap();
let string = "GEOL_Laramide_Fault_Density_Cu_JGEM";
let substitution = "\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}