using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"GEO[P|L]\_(.*)\_JGEM";
string substitution = @"\1";
string input = @"GEOL_Laramide_Fault_Density_Cu_JGEM";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}