use strict;
my $str = 'GEOL_Laramide_Fault_Density_Cu_JGEM';
my $regex = qr/GEO[P|L]\_(.*)\_JGEM/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";