# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/GEO[P|L]\_(.*)\_JGEM/\1/gm;t' <<< "GEOL_Laramide_Fault_Density_Cu_JGEM"