re = /GEO[P|L]\_(.*)\_JGEM/m
str = 'GEOL_Laramide_Fault_Density_Cu_JGEM'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result