#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)GEO[P|L]\_(.*)\_JGEM"
Local $sString = "GEOL_Laramide_Fault_Density_Cu_JGEM"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)