$re = '/GEO[P|L]\_(.*)\_JGEM/m';
$str = 'GEOL_Laramide_Fault_Density_Cu_JGEM';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;