re = /(<\?php echo L10n\:\:icon\('timeago'\); \?>)(\n)(\s+)(<\?php echo UI\:\:timeago)/m
str = '<?php echo L10n::icon(\'timeago\'); ?>
<?php echo UI::timeago($Camera->iso_8601_processed, $Camera->processed); ?>'
subst = '$4'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result