const regex = /(<\?php echo L10n\:\:icon\('timeago'\); \?>)(\n)(\s+)(<\?php echo UI\:\:timeago)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<\\?php echo L10n\\:\\:icon\\(\'timeago\'\\); \\?>)(\\n)(\\s+)(<\\?php echo UI\\:\\:timeago)', 'gm')
const str = `<?php echo L10n::icon('timeago'); ?>
<?php echo UI::timeago(\$Camera->iso_8601_processed, \$Camera->processed); ?>`;
const subst = `$4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);