use strict;
my $str = '<?php echo L10n::icon(\'timeago\'); ?>
<?php echo UI::timeago($Camera->iso_8601_processed, $Camera->processed); ?>';
my $regex = qr/(<\?php echo L10n\:\:icon\('timeago'\); \?>)(\n)(\s+)(<\?php echo UI\:\:timeago)/mp;
my $subst = '$4';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";