using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<\?php echo L10n\:\:icon\('timeago'\); \?>)(\n)(\s+)(<\?php echo UI\:\:timeago)";
string substitution = @"$4";
string input = @"<?php echo L10n::icon('timeago'); ?>
<?php echo UI::timeago($Camera->iso_8601_processed, $Camera->processed); ?>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}