import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<\\?php echo L10n\\:\\:icon\\('timeago'\\); \\?>)(\\n)(\\s+)(<\\?php echo UI\\:\\:timeago)";
final String string = "<?php echo L10n::icon('timeago'); ?>\n"
+ " <?php echo UI::timeago($Camera->iso_8601_processed, $Camera->processed); ?>";
final String subst = "$4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}