import Foundation
let pattern = #"<img.*?src="([^"]*)"[^>]*>(?:</img>)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
<b>More</b> <strike>formatting</strike> and stuff<br><br><p class="image-placeholder"><img src="http://test.com/image1.gif" alt="" class="" style="width: 100%" title="">Text <b>after</b> image<i></i></p> src is cool
<img alt="" class="" src="http://test.com/image2.gif" style="width: 100%" title=""></img>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)