#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)<img.*?src="([^"]*)"[^>]*>(?:</img>)?"
Local $sString = "<b>More</b> <strike>formatting</strike> and stuff<br><br><p class="image-placeholder"><img src="http://test.com/image1.gif" alt="" class="" style="width: 100%" title="">Text <b>after</b> image<i></i></p> src is cool" & @CRLF & _
"" & @CRLF & _
"<img alt="" class="" src="http://test.com/image2.gif" style="width: 100%" title=""></img>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")