// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?i)<img.*?src="([^"]*)"[^>]*>(?:</img>)?"#).unwrap();
let string = "<b>More</b> <strike>formatting</strike> and stuff<br><br><p class=\"image-placeholder\"><img src=\"http://test.com/image1.gif\" alt=\"\" class=\"\" style=\"width: 100%\" title=\"\">Text <b>after</b> image<i></i></p> src is cool
<img alt=\"\" class=\"\" src=\"http://test.com/image2.gif\" style=\"width: 100%\" title=\"\"></img>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}