using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<img.*?src=""([^""]*)""[^>]*>(?:</img>)?";
string input = @"<b>More</b> <strike>formatting</strike> and stuff<br><br><p class=""image-placeholder""><img src=""http://test.com/image1.gif"" alt="" class="" style=""width: 100%"" title="">Text <b>after</b> image<i></i></p> src is cool
<img alt="" class="" src=""http://test.com/image2.gif"" style=""width: 100%"" title=""></img>";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}