$re = '/<img.*?src="([^"]*)"[^>]*>(?:</img>)?/i';
$str = '<b>More</b> <strike>formatting</strike> and stuff<br><br><p class="image-placeholder"><img src="http://test.com/image1.gif" alt="" class="" style="width: 100%" title="">Text <b>after</b> image<i></i></p> src is cool
<img alt="" class="" src="http://test.com/image2.gif" style="width: 100%" title=""></img>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);