import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<img.*?src=\"([^\"]*)\"[^>]*>(?:</img>)?";
final String string = "<b>More</b> <strike>formatting</strike> and stuff<br><br><p class=\"image-placeholder\"><img src=\"http://test.com/image1.gif\" alt=\"\" class=\"\" style=\"width: 100%\" title=\"\">Text <b>after</b> image<i></i></p> src is cool\n\n"
+ "<img alt=\"\" class=\"\" src=\"http://test.com/image2.gif\" style=\"width: 100%\" title=\"\"></img>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}