use strict;
my $str = '<b>More</b> <strike>formatting</strike> and stuff<br><br><p class="image-placeholder"><img src="http://test.com/image1.gif" alt="" class="" style="width: 100%" title="">Text <b>after</b> image<i></i></p> src is cool
<img alt="" class="" src="http://test.com/image2.gif" style="width: 100%" title=""></img>';
my $regex = qr/<img.*?src="([^"]*)"[^>]*>(?:</img>)?/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}