const regex = /<img.*?src="([^"]*)"[^>]*>(?:</img>)?/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<img.*?src="([^"]*)"[^>]*>(?:<\/img>)?', 'gi')
const str = `<b>More</b> <strike>formatting</strike> and stuff<br><br><p class="image-placeholder"><img src="http://test.com/image1.gif" alt="" class="" style="width: 100%" title="">Text <b>after</b> image<i></i></p> src is cool
<img alt="" class="" src="http://test.com/image2.gif" style="width: 100%" title=""></img>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}