import Foundation
let pattern = #"(.+)@(.+)(\.[a-zA-Z1-9]{2,6})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
goose@down.com
blah@192.168.1.255
blah@255.255.255.255
blah@0.0.0.0
gah@1.1.1.01
blah@127.0.0.1
blah@192.168.1.1
blah@domain.com
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}