const regex = /(.+)@(.+)(\.[a-zA-Z1-9]{2,6})/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.+)@(.+)(\\.[a-zA-Z1-9]{2,6})', '')
const str = `
goose@down.com
blah@192.168.1.255
blah@255.255.255.255
blah@0.0.0.0
gah@1.1.1.01
blah@127.0.0.1
blah@192.168.1.1
blah@domain.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}