package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(.+)@(.+)(\.[a-zA-Z1-9]{2,6})`)
var str = `
goose@down.com
blah@192.168.1.255
blah@255.255.255.255
blah@0.0.0.0
gah@1.1.1.01
blah@127.0.0.1
blah@192.168.1.1
blah@domain.com`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}