#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(.+)@(.+)(\.[a-zA-Z1-9]{2,6})"
Local $sString = "" & @CRLF & _
"goose@down.com" & @CRLF & _
"blah@192.168.1.255" & @CRLF & _
"blah@255.255.255.255" & @CRLF & _
"blah@0.0.0.0" & @CRLF & _
"gah@1.1.1.01" & @CRLF & _
"blah@127.0.0.1" & @CRLF & _
"blah@192.168.1.1" & @CRLF & _
"blah@domain.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")