# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(.+)@(.+)(\.[a-zA-Z1-9]{2,6})"
test_str = ("\n"
"goose@down.com\n"
"blah@192.168.1.255\n"
"blah@255.255.255.255\n"
"blah@0.0.0.0\n"
"gah@1.1.1.01\n"
"blah@127.0.0.1\n"
"blah@192.168.1.1\n"
"blah@domain.com")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.