$re = '/(.+)@(.+)(\.[a-zA-Z1-9]{2,6})/';
$str = '
goose@down.com
blah@192.168.1.255
blah@255.255.255.255
blah@0.0.0.0
gah@1.1.1.01
blah@127.0.0.1
blah@192.168.1.1
blah@domain.com';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);