using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.+)@(.+)(\.[a-zA-Z1-9]{2,6})";
string input = @"
goose@down.com
blah@192.168.1.255
blah@255.255.255.255
blah@0.0.0.0
gah@1.1.1.01
blah@127.0.0.1
blah@192.168.1.1
blah@domain.com";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}