// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(.+)@(.+)(\.[a-zA-Z1-9]{2,6})").unwrap();
let string = "
goose@down.com
blah@192.168.1.255
blah@255.255.255.255
blah@0.0.0.0
gah@1.1.1.01
blah@127.0.0.1
blah@192.168.1.1
blah@domain.com";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}