// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d+\t(\S*)\t(\S*)").unwrap();
let string = "49 Abu Dhabi --- 7GtTwl-Sn Mercedes-Benz Cars Middle East FZE
مرسيدس-بنز الشرق الأوسط
OPEN
x (x) x
45 Argentina xVhWF6eMY -TU4MkuYw Mercedes-Benz Argentina S.A.U.
LIVE
x (x)
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}