import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d+\\t(\\S*)\\t(\\S*)";
final String string = "49 Abu Dhabi --- 7GtTwl-Sn Mercedes-Benz Cars Middle East FZE\n"
+ "مرسيدس-بنز الشرق الأوسط \n"
+ "OPEN\n\n"
+ "x (x) x \n\n\n\n\n\n\n\n\n"
+ "45 Argentina xVhWF6eMY -TU4MkuYw Mercedes-Benz Argentina S.A.U. \n"
+ "LIVE\n\n"
+ "x (x) \n\n\n\n\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}