const regex = /\d+\t(\S*)\t(\S*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\d+\\t(\\S*)\\t(\\S*)', 'gm')
const str = `49 Abu Dhabi --- 7GtTwl-Sn Mercedes-Benz Cars Middle East FZE
مرسيدس-بنز الشرق الأوسط
OPEN
x (x) x
45 Argentina xVhWF6eMY -TU4MkuYw Mercedes-Benz Argentina S.A.U.
LIVE
x (x)
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}