#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\d+\t(\S*)\t(\S*)"
Local $sString = "49 Abu Dhabi --- 7GtTwl-Sn Mercedes-Benz Cars Middle East FZE" & @CRLF & _
"مرسيدس-بنز الشرق الأوسط " & @CRLF & _
"OPEN" & @CRLF & _
"" & @CRLF & _
"x (x) x " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"45 Argentina xVhWF6eMY -TU4MkuYw Mercedes-Benz Argentina S.A.U. " & @CRLF & _
"LIVE" & @CRLF & _
"" & @CRLF & _
"x (x) " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")