# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\d+\t(\S*)\t(\S*)"
test_str = ("49 Abu Dhabi --- 7GtTwl-Sn Mercedes-Benz Cars Middle East FZE\n"
"مرسيدس-بنز الشرق الأوسط \n"
"OPEN\n\n"
"x (x) x \n\n\n\n\n\n\n\n\n"
"45 Argentina xVhWF6eMY -TU4MkuYw Mercedes-Benz Argentina S.A.U. \n"
"LIVE\n\n"
"x (x) \n\n\n\n\n\n\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.