re = /\d+\t(\S*)\t(\S*)/m
str = '49 Abu Dhabi --- 7GtTwl-Sn Mercedes-Benz Cars Middle East FZE
مرسيدس-بنز الشرق الأوسط
OPEN
x (x) x
45 Argentina xVhWF6eMY -TU4MkuYw Mercedes-Benz Argentina S.A.U.
LIVE
x (x)
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end