use strict;
my $str = '49 Abu Dhabi --- 7GtTwl-Sn Mercedes-Benz Cars Middle East FZE
مرسيدس-بنز الشرق الأوسط
OPEN
x (x) x
45 Argentina xVhWF6eMY -TU4MkuYw Mercedes-Benz Argentina S.A.U.
LIVE
x (x)
';
my $regex = qr/\d+\t(\S*)\t(\S*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}