package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d+\t(\S*)\t(\S*)`)
var str = `49 Abu Dhabi --- 7GtTwl-Sn Mercedes-Benz Cars Middle East FZE
مرسيدس-بنز الشرق الأوسط
OPEN
x (x) x
45 Argentina xVhWF6eMY -TU4MkuYw Mercedes-Benz Argentina S.A.U.
LIVE
x (x)
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}