import Foundation
let pattern = #"http:\/\/www\.planetrugby\.com\/gallery\/story\/([0-9,_])*\.html$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"http://www.planetrugby.com/gallery/story/0,25928,9825_9179877,00.html"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}