// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)http:\/\/www\.planetrugby\.com\/gallery\/story\/([0-9,_])*\.html$").unwrap();
let string = "http://www.planetrugby.com/gallery/story/0,25928,9825_9179877,00.html";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}