re = /http:\/\/www\.planetrugby\.com\/gallery\/story\/([0-9,_])*\.html$/i
str = 'http://www.planetrugby.com/gallery/story/0,25928,9825_9179877,00.html'
# Print the match result
str.match(re) do |match|
puts match.to_s
end