use strict;
my $str = 'http://www.planetrugby.com/gallery/story/0,25928,9825_9179877,00.html';
my $regex = qr/http:\/\/www\.planetrugby\.com\/gallery\/story\/([0-9,_])*\.html$/ip;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}