#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)http:\/\/www\.planetrugby\.com\/gallery\/story\/([0-9,_])*\.html$"
Local $sString = "http://www.planetrugby.com/gallery/story/0,25928,9825_9179877,00.html"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")