$re = '/http:\/\/www\.planetrugby\.com\/gallery\/story\/([0-9,_])*\.html$/i';
$str = 'http://www.planetrugby.com/gallery/story/0,25928,9825_9179877,00.html';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);