package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)http:\/\/www\.planetrugby\.com\/gallery\/story\/([0-9,_])*\.html$`)
var str = `http://www.planetrugby.com/gallery/story/0,25928,9825_9179877,00.html`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}