const regex = /http:\/\/www\.planetrugby\.com\/gallery\/story\/([0-9,_])*\.html$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('http:\\\/\\\/www\\.planetrugby\\.com\\\/gallery\\\/story\\\/([0-9,_])*\\.html$', 'i')
const str = `http://www.planetrugby.com/gallery/story/0,25928,9825_9179877,00.html`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}